软件简介

里诺仓库管理软件帮助

感谢:

感谢您使用里诺仓库管理软件(SQL网络版)，软件的后台数据库使用的是MS SQL Server2000,软件具有安全度高,速度快等特点,特别适合数据量大的公司.软件完全可以满足中小型企业的要求，程序启动后如下图所示

合理使用本软件，可帮助您提高工作效率和业绩。

第一次使用
如果您是第一次使用本软件，请阅读"操作手册"。

在使用中碰到问题的解决办法：
1.如果您在使用软件的过程中碰到问题，请先在本帮助文档中寻找答案。

2. 如果通过以上措施还找不到满意的答案，请访问本公司的网站寻求帮助。
或者您可以在论坛发布描述该问题的文章。

3.如果论坛中也找不到满意的解决办法，请写电子邮件给我们公司的技术支持:
客 服 QQ: 171755331 16380858
售 后 QQ: 759782126
客服电话: 0714-6252277 400-670-2577转1
手机：(0)18672215522
希望我们的服务能使您满意。


安装与配置
里诺仓库管理软件(SQL网络版)后台数据库采用的是SQL Server2000,所以您需要安装MSDE(微软数据库引擎),您可以到我们的网站去下载。我们的网站是:http://www.lenosoft.net
注意,MSDE只能在Windows2000及其以后的版本中安装,这意味着Windows98及其以前的用户不能使用里诺仓库管理软件(SQL网络版)。

第一步:安装MSDE
MSDE下载下来后,直接点击EXE文件进行安装.安装完成后您可以在Windows的[开始]->程序->启动中找到Service Manager.这表明您的MSDE已安装成功.

第二步 启动MSDE
在启动栏中点击Service Manager,运行SQL,此时Windows的任务栏会有如下图标显示.

如果图标不是绿色的箭头,您可以双击它,在如下的窗体中点击[开始\继续]按钮.

第三步 安装数据库
安装里诺仓库管理软件(SQL网络版),安装完成后点击主程序运行,这时会有"连接数据库失败,是否要重新配置数据库",先是,这时弹出的窗体如下图所示:

先点击测试连接按钮,如提示连接成功再点击安装数据库按钮,如提示数据库安装成功,则里诺仓库管理软件(SQL网络版)已完装成功. 如提示安装数据库失败,如服务器一栏仍不空,请手工录入(Local),再点击安装数据库按钮,如还不能安装成功,请和我们联系,由我们来为您解答.

如果程序安装失败,请您参见手工安装数据库.

如何联网使用?
在客户端安装好里诺仓库管理软件(SQL网络版)(客户端不用再安装MSDE了),如果连接失败,则在弹出的配置窗体中中的服务器一栏输入安装了MSDE的电脑的机器名.然后点击"测试连接",如提示连接成功,你就可以正常使用我们的网络版的软件了.
如提示连接失败,请参见ODBC配置

注意:
如果您按照我们的帮助安装的，仍然提示数据库连接失败，那可能是您的SQL不是"混合验证模式"。解决的方法是打开注册表，单击Windows的"开始"->"运行"，输入"Regedit",把"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode"改为0，重启电脑后数据库应该就可以连接上了(如果重启电脑上仍然连不上,可以把LoginMode改成1再重启电脑试试)。


数据库安装和设置

数据库安装

 SQL Server的验证模式: 如果您按照我们的帮助安装的，仍然提示数据库连接失败，那可能是您的SQL不是"混合验证模式"。解决的方法是打开注册表，单击Windows的"开始"->"运行"，输入"Regedit",把"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode"改为0，重启电脑后数据库应该就可以连接上了(如果重启电脑上仍然连不上,可以把LoginMode改成1再重启电脑试试)。

里诺仓库管理软件(SQL网络版)采有的数据库是SQL Server2000,请先在你的服务器上安装MSDE(我们的网站提供下载).

在安装目录找到DBlinker.exe,选择Local(如果没有选择项,则在服务器栏上输入(Local)),先点击"测试连接"按钮,如果程序提示连接数据库成功,再点击"安装数据库"按钮,如提示成功数据库就被安装上去了.

客户端如何连接服务器上的数据?
在任何一个客户机上安装里诺仓库管理软件(SQL网络版),运行DBlinker.exe,在服务器栏上选择服务器(即安装了MSDE或SQL2000的电脑)的机器名或IP地址,点击测试连接,如提示连接成功,程序就可连接上服务器上的数据库.
如果连接数据库总是不能成功,请通过ODBC来测试一下.查看客户端连接设置.


客户端连接设置

如果客户端出现“数据库连接失败”错误提示导致软件不能正常使用，您需要修改您的客户端配置。如果服务端也不能连接成功也可以通过ODBC测试连接一下,下面以Windows2000为例：

1、打开控制面板->管理工具->ODBC(数据源),如下图所示：

2、点击"Add"按钮，此时出现在的窗体如下图所示，在列表中选择“SQL Server”,然后点击"完成"按钮。

3、在下面窗体的Name输入框中随便输入一个名称，在[服务器]一栏中输入服务器(即安装了MSDE或SQL2000的电脑)的机器名或IP地址 然后点击“下一步”按钮。
(注意,如果服务端也连接数据库不成功,也可以用ODBC测试一下连接,在服务器一栏中输入(local)或服务器的机器名即可)

4、此时出现的窗体如下图所示，选择“使用用户输入登录ID和密码和SQL Server验证”这一项。
把"连接SQL Server以获得其它配置选项的默认设置"在"登录ID" ID一项输入“sa”,"密码"一项可以保持为空（如果您的SQL有密码，请输入正常的密码），然后点击“客户端配置”按钮。

5、在“网络库”选择“TCP/IP”，然后点击“OK”按钮。

6、点击[OK]按钮,退出[Add Network library Configuration]窗体,在[Microsoft SQL Server Configuration]窗体上点击下一步按钮,此时出现的窗体如下图所示:

7、设置完成,此时再启动里诺仓库管理软件(SQL网络版),应能正确连接上SQL.


恢复数据库

如果您因电脑操作系统重装,需要把以前备份的数据库恢复过来,请您按如下操作来做,首先,您需要安装MS SQL Server2000.
1. 以Windowns XP为例,SQL Server企业版安装完成后,点击Windows的菜单"开始"->"程序"->"Microsoft SQL Server"->"企业管理器",就可以打开企业管理器了,如下图所示

2. 运行企业管理器,依次展开"Microsoft SQL Servers"->"SQL Server组"->"Local(注:您的机器名)"->"数据库".选中数据库,右击鼠标,选择"所有任务"->"还原数据库",如下图所示:

3. 点击"还原数据库"菜单后,出现如下窗体.输入还原的数据库名称,选择"从设备"

4. 点击"选择设备"按钮,单击"添加"按钮,在文件名项选择您的备份文件,然后点击确定按钮.
回到"选择还原设备"窗体,点击"确定"按钮退出"选择还原设备"窗体.

5.在"还原数据库"窗体,点击"选项"面板,如下图所示:
在移至物理文件名中,请为两个数据库文件选择一个路径. 比如,如果D盘下有一个DataBase的文件夹(当然其它文件夹也可以,最好是英文的文件夹),我可以把它改为"D:\database\depot_data.mdf"和"D:\database\depot_log.ldf"
注意,D盘的database文件夹必需存在才行,否则还原数据会失败,如果失败,把路径设成一个存在的路径即可

6 点击"还原数据库"窗体上的"确定"按钮,这时程序会提示你"还原数据库成功"(如下图所示).如果还原失败,请您仔细核对以前步骤,


附加数据库
如果程序添加数据库失败,请您手工添加数据库.

1. 打开企业管理器,依次展开企业管理器中的控制台目录,[控制台目录]->[Microsoft SQL Servers]->[local]->[数据库],在数据库项上右击鼠标会出现一个菜单,如下图所示:

2. 点击菜单"所有任务"->"附加数据库",出现的界面如下图所示:

选择一个MDF文件(找到里诺仓库管理软件(SQL网络版)程序的安装路径,选择Database文件夹下面的mdf文件(database此时应该有两个文件,都是数据库文件),在附加为输入框中输入"Depot",点击确定.数据库即成功安装.


基础资料

前言: 软件安装好后,下一步需要录入好基础资料,如仓库名称,往来单位和货品资料等,基础资料建好后,您能更快更方便地使用里诺仓库管理软件(SQL网络版).

第一步: 数据初始化
我们的试用版的软件里面就存有一些演示数据,在开始录入您公司的基础资料前,您需要先把软件里面的演示数据删除以便录入您公司的基础资料.点击软件主界面上面的菜单[系统设置]->[数据初始化],进入数据初始化界面(如下图所示),点击[清除]按钮,如系统提示数据初始化成功,接下来您就可以开始基础资料的录入了.

第二步: 录入仓库资料
点击软件主界面上的菜单[基础资料]->[仓库资料]，进入仓库资料管理窗口，如下图所示。

单击[新增]按钮，在名称框内输入一个仓库名，再点击[保存]按钮，则仓库资料保存到软件里面去了.
注意：仓库名称不能重复!

第三步: 往来单位资料管理
点击软件主界面上的菜单[基础资料]->[来往单位]->[往来单位资料]，进入往来单位资料管理窗体，如下图所示。

单击新增按钮，在基本资料中输入单位信息，再点击保存按钮，该单位的资料即保存进去了。

第四步 货品资料管理
货品资料管理是基础资料管理中最重要,也是录入数据工作量最大的一项,点击软件主界面上的菜单[基础资料]->[货品资料]->[货品资料管理],进入货品资料管理窗体，如下图所示。

点击货品资料列表窗体上的[新增]按钮,在新增货品资料窗体(如下图所示)填写好货品编码，货品名称,货品规格，期初库存量等信息，然后点击[保存]按钮，货品资料就保存进软件了,此时文本框内的信息软件自动清空以待下一条记录的录入。添加完所有的货品资料后,就可以点击[退出]按钮关闭新增货品资料窗体!.

名词解释:
[自动]：添加货品资料窗体上有一个名称为[自动]的单选项 [image],打上勾时软件会自动为您生成货品编码(如A0001后自动变成A0002,软件自动加1,减轻您的手工录入的工作量),但货品编码的最后四位必须为数字,否则软件不能为您自动生成货品编码.如果您想按自己公司的货品编码规则来,请把自动单选项前的勾去掉.
[入库价]：当您录入入库单据时，入库价作为默认单价;
[出库价]：当您录入出库单据时，入库价作为默认单价;
[期初库存数]：您必须录入一个期初库存数!

货品分类管理
当货品资料很多时,这时为货品资料归好类就显得很重要了(多达几千条甚至上万条的货品资料,足以让您眼花缭乱了),我们的软件采用树形分类,即大类可以有多个小类,小类下面又可以有多个小类,采用树形分类能让您更直观的管理货品资料.进入货品资料分类管理界面,请点击软件主界面上菜单[基础资料]->[货品资料]->[货品资料分类管理]，弹出如下所示的货品资料分类管理窗体：

注意：货品类别的编码必须是偶数，即只能是两位数，四位数和六位数...

注:移动加权平均法是计算机会计信息系统可采用的最优方法。采用移动加权平均法，每次收入存货后，立即根据现有存货的总价值和总数量计算出新的单位成本。每发出一批存货都要根据发出存货的数量和前一次进货时计算的平均单位成本确定发出存货成本和结存存货的价值，这种方法能及时提供存货的成本资料。在手工条件下移动加权平均成本法因计算工作相当繁琐、计算量太大而很少采用，但在计算机条件下，计算机高速计算的优势正好弥补了这一缺陷，使移动加权平均法在实际工作中具有可操作性，并且对暂估入库存货的成本的确定非常有利。 通过分析可知：移动加权平均法所确定的存货单价在一定程度上应该说是最接近暂估存货实际单价的，而且这一方法在计算机条件下可以充分发挥其长处，克服其弱势，移动加权平均法是计算机会计信息系统中确定暂估存货入账价值的最佳选择。
注意：如果您单据中引用了某个货品，则不能删除该货品。


所有单据

单据录入

 如果您是第一次使用本软件，您需要把程序里面演示数据全都清除掉，从下拉菜单[系统设置]选择[清除数据]，点击确定即完成清除工作。此时程序中的各种单据和货品资料都清除完毕了。
我们的单据共分为采购收货,销售退货,产品入库,领用退回,借货入库,借出还入,采购退货,销售出货,领用出库,借货出库,借入还出,库存盘点,仓库调拨.下面是单据录入界面.

如何查看录入的单据?
选择下拉菜单[数据查询]->[单据查询]，程序即会把所有的单据都列出来。 如下图所示:


出库

货品出库
我们以销售提货出库为例:

一.销售提货出库单.
在[出库登记]单击[销售提货出库],如下图所示:

点击[增行]按钮(或单击表中的[...]按钮)来添加货品, 填写好单价和数据后, 最后在单据添加界面点击[保存]按钮,至此完成货品出库.


入库

货品入库

我们以采购收货入库为例:

一.采购收货入库单.
在[入库登记]单击[采购收货入库],此时出现的界面如下图所示:

二.添加货品.
在采购收货入库单据中点击新增按钮,选择入库日期,仓库和供应商等信息.

添加货品,点击[增行]按钮(或单击表格中的[...]按钮)来添加货品, 填写好单价和数据后,此时出现的界面如下图所示,选择一个要入库的货品,在表格中双击完成添加.

最后在单据添加界面点击[保存]按钮,至此完成货品入库.


盘点和调拨

库存盘点和调拨
库存盘点和调拨[其它登记]中,如下图所示

点击[增行]按钮(或单击表中的[...]按钮)来添加货品, 填写好单价和数据后, 最后在单据添加界面点击[保存]按钮,至此完成添加.

注意，如果货品编号为001的货品的实际库存是100,而软件中显示的库存数是80,你在填写盘点单时数量输入20,这样该货品在软件中的库存量就是100了.


查找单据

 点击里诺仓库管理软件(SQL网络版)的主菜单[数据查询] -> [单据查询]，进入单据查询窗体，如下图所示。

进入到查询单据界面，在业务类别选择要查找单据的类别(如采购收货、销售提货),还可以按单号、开单人、日期范围等信息进行查找，设置好查找的条件后，请单击[查找]按钮，则在列表中显示所有与查询条件匹配的记录，用鼠标选定一条记录，然后点击[显示单据]按钮，或直接用鼠标在选定的记录上双击，则可以显示出此单据，然后可以对单据进行修改或查阅。


报表设计
里诺仓库管理软件(SQL网络版)的单据报表样式支持自定义,下面我们以设计入库单为例;

点击软件主界面上的菜单"系统设置"->"报表设计"->"入库单据报表设计",此时设计界面如下图所示:

如何改变报表的纸张大小?
点击报表设计窗体中的菜单"文件"->"页面属性",此时出现的界面如下图所示:

您可以自己修改单据的宽高,还有是横打还是纵打.

如何改变报表中文字?
比如我想把报表中原有的货品名称改成品名,可以用鼠标选中"货品名称"字段,如下图所示

  • 货名名称现在处于选中状态,保持选中状态(注意:边框四个角有黑点才表明选中),然后直接双击,在随后出现的窗体中改成品名后,点击保存即可.

    如何修改小数点位数?
    您可以自定义单价,数量和金额的小数点打印位数,下面我们以修改单价的小数点位数为例.选用"MasterData"中的单价项,如下图所示,右击鼠标,在右键菜单中选择"Display Format(显示格式)",比如我想显示成2位,在显示格式窗体中把格式字串把 %2.6f 改成 %2.2f

  • 如果您想套打,您可以把报表中的边框钱和有中文字的文本框都删除.
  • 如果您想把货品资料整行下移,选中"Report title".让它处于选中状态,把鼠标移到"Report title"下边框中间的那个黑点处,鼠标变成上下箭头,把Report title高度拖长一些即可.
    设计完成后,点击保存报表设置即完成设计.此时单据样式已变成您设计的样式.

    小窍门:按住"Ctrl"键+上下左右方向键,可以实现精确移动(只移一个像素).
    按住"Ctrl"还可以实现连选.

            •


软件升级

 如果您使用的是里诺仓库管理软件(SQL网络版)的老版本,而您又想使用里诺仓库管理软件最新版的软件,您可以按照如下方法来升级.

1 安装数据库
把最新版的里诺仓库管理软件(SQL网络版)安装到一个新的目录,然后使用新版本目录的数据库配置工具,把默认的数据库名"Depot"改成"Depot2005"(总之数据库名不要再叫Depot,只要您容易区分就行了).

2 从老版本导入数据
找到新版本的安装目录,运行"upgrade.exe",先择老版本的数据库名,点击下一步,按照程序的提示即可轻松完成升级.


如何从单机版升级到网络版

 如果您使用的是里诺仓库管理软件(单机版),而您现在想使用里诺仓库管理软件(SQL网络版)软件,您可以按照如下方法来升级.

找到里诺仓库管理软件(SQL网络版)的安装目录,运行"Access.exe",先择单机版的数据库名,点击下一步,按照程序的提示即可轻松完成升级.


注 意 事 项

 使用软件之前，请将日期格式设置为标准格式如：2003-10-19如果日期格式设置为03-10-19这样的格式，系统会产生错误。 设置方法一：从开始菜单选择设置/控制面板,打开控制面板后，选择区域设置,在区域设置窗口打开后，再选择日期选项卡，然后在短日期样式一栏中选择yyyy-mm-dd,然后单击确定按钮即可。


单据配置

单据种类配置

如果您需要新增一些单据类型,可按如下操作.点击软件主面上的菜单"系统设置"->"配置单据",如下图所示:
您可以在这里配置您需要的单据种类,配置完成后,重启里诺仓库管理软件(SQL网络版),重新登录软件就可以看到您刚才配置的单据种类了.


疑难解答FAQs

里诺仓管疑难解答 FAQs

  • 单报报表的报表样式可以修改吗?如何修改?
  • 库存报警如何使用?
  • 为什么仓管软件装好了,而我却不能试用?
  • 软件我刚装好,现在我想把里面的初始数据删除掉,我该怎么做?
  • 我想使用最新的仓管软件,请问我该如何正确升级?
  • 我购买注册之后,我以前录入的数据都还在吗?
  • 为什么我导出的Excel文件许多都是乱码?
  • 我的库管软件老是提示"数据库连接失败",然后程序就不能运行了?
  • 请问里诺仓管支持Internet联网吗?
  • 我想自定义仓管软件的启动界面并把软件的名称改成我们公司的名称,比如某某公司仓管软件,请问可以吗?
  • 请问如何重新安装新版本的软件?

    • 问:单报报表的报表样式可以修改吗?如何修改?
    答:我们的报表采用的是FastReport,它支持用户自定义,这意味着你可以改变报表的样式(如纸张大小,字段的位置,增加自己公司的标识等等).
    选择菜单 "系统设置"->"报表设置" 里您可以分别修改入库单和出库单的样式.

    问:库存报警如何使用?
    答:在货品资料编辑窗体中设置好某一货品的库存上限和库存下限值,这样当该货品的总库存数量超过库存上限和低于库存下限时,在库存报警中该货品资料就会示出来,起到警示的作用.

    问:为什么仓管软件装好了,而我却不能试用?
    答:在Windows98和Windows Me中,里诺仓管软件的很多功能按钮将会是灰色的,您需要去下载MDAC2.8,然后安装升级即可解决在98和WinMe中不能用的问题了.
    如果您还发现在其它操作系统中不能使用,请向我们报告.lenosoft@21cn.com
    MDAC在我们的网站上有下载,您也可以在网上搜索下载.

    问:软件我刚装好,现在我想把里面的初始数据删除掉,我该怎么做?
    答:选择菜单 "系统设置"->"数据初始化" ,把您需要清除的项目打上勾点击确定就行了.

    问:我想使用最新的仓管软件,请问我该如何正确升级?
    答:在程序之前请先把您的数据库做好备份,见菜单"系统设置"->"数据库备份" 选择菜单 "实用工具"->"数据库升级工具" ,然后选择您以前的老的数据库点击下一步,在程序的提示下就可以顺利完成升级.

    问:我购买注册之后,我以前录入的数据都还在吗?
    答:当然,注册后您的数据仍在.

    问:为什么我导出的Excel文件许多都是乱码?
    答:我们的软件目前只对Office2000支持较好,如果乱码的情况可能是您的电脑装的是Office2003的缘故,您可以换一台装有Office2000的电脑试试.

    问:我的库管软件老是提示"数据库连接失败",然后程序就不能运行了?
    答:首先请确认您的数据库文件是否已经安装,可见    安装与配置.

    问:请问里诺仓管支持Internet网吗?
    答:里诺仓管SQL网络版支持,但前提是您必须要有一台通过公网上网的电脑作为存放数据的服务器,有个固定的IP最好.

    问:我想自定义仓管软件的启动界面并把软件的名称改成我们公司的名称,比如某某公司仓管软件,请问可以吗?
    答:可以,修改启动封面您只需要把里诺仓管软件目录下面的splash.bmp替换成您的文件就行了.修改软件的名称见菜单"系统设置"->"系统设置"里.

    问:请问如何重新安装新版本的软件?
    答:注意,不同版本的软件一般不能混用的,比如您以前安装过2.60版本的,现在想试用2.65的,如果里面的数据不重要,可以用如下方法来安装2.65版的:
    1 先停掉SQL的服务;
    2 再把2.60版的软件卸载掉,再按原路径安装2.65版;
    3 再开启SQL服务就可以了.
    注意,以上方法以前版本的数据会全部丢失.

    以上只是我们一部分的答疑,如果您的问题不在上面,您可以给我们写信:     lenosoft@21cn.com


注 册 购 买

"里诺仓库管理软件 SQL网络版"为共享软件,需注册才能永久使用全部功能并享受免费升级服务。没有注册只能录入50张单据。

里诺仓库管理软件 SQL网络版的注册费用为 680 元一台电脑,注册购买后您将得到光盘一张和正式发票.
您注册后可以享受软件的一年的免费升级服务，并且还可以得到我们的技术支持服务!

软件注册方法
选择菜单“帮助文件”->“软件注册购买”，则弹出如下窗体，输入正确的注册码，点击“注册”按钮便可。

注意,购买后请用电子邮件告知您的机器码,见下图.

银行帐号:
开 户 行：招商银行黄石挹江支行
帐　　号：6225 8071 4007 1642
开 户 人：任章勇

开 户 行：中国农业银行黄石市分行胜阳港支行
帐　　号：95599 8076 93415 27216
开 户 人：任章勇

开 户 行：中国工商银行黄石市分行挹江支行
帐　　号：9558 8218 0300 0017915
开 户 人：任章勇

邮政汇款:
开户局名称:黄石天津路邮政所
帐号:60522 0004 2011 57699
户名:任章勇
邮编:435000

支付注册费之后，请填写以下注册信息，通过邮件发送给我们，我们的邮件地址是：lenosoft@21cn.com

汇款方式：填写银行名称,比如工行,农行或招行
企业名称：
地址及邮编：
联系电话：
Email：
汇款人姓名:
汇款金额：

服务承诺

凡是购买我们软件的用户，我们会在48小时以前给您寄出注册码。
如果您是在线购买注册的，只要您银行转帐成功，系统会自动给您发送注册码，而你也同样成为我们的正式用户，享有我们以后为您提供的升级服务和咨询服务。

联系方法

如有疑问或任何建议请与我们联系
联系方法:
客 服 QQ: 171755331 16380858
售 后 QQ: 759782126
客服电话: 0714-6252277 400-670-2577转1
手机：(0)18672215522