软件简介

软件帮助

感谢:

感谢您使用里诺仓库管理软件(SQL工程版)，软件的后台数据库使用的是MS SQL Server2000(中文版)，里诺仓库管理软件(SQL工程版)启动后如下图所示

合理使用本软件，可帮助您提高工作效率和业绩。

第一次使用
如果您是第一次使用本软件，请阅读"操作手册"。

在使用中碰到问题的解决办法：
1， 如果您在使用软件的过程中碰到问题，请先在本帮助文档中寻找答案。

2， 如果通过以上措施还找不到满意的答案，请访问本公司的网站寻求帮助。
或者您可以在论坛发布描述该问题的文章。

3， 如果论坛中也找不到满意的解决办法，请写电子邮件给我们公司的技术支持:
电邮地址: lenosoft@21cn.com
客 服 QQ: 171755331 16380858
售 后 QQ: 759782126
客服电话: 0714-6252277 400-670-2577转1
手机：(0)18672215522
希望我们的服务能使您满意。


安装与配置
里诺仓库管理软件(SQL工程版)采用的是SQL2000作为数据库,所以您需要安装MSDE(即微软数据库引擎,有60M),您可以到我们的网站去下载。我们的网站是:http://www.lenosoft.net
注意,MSDE只能在Windows2000及其以后的版本中安装,这意味着Windows98及其以前的用户不能使用里诺仓库管理软件(SQL工程版)。

第一步:安装MSDE
MSDE下载下来后,直接点击EXE文件进行安装.安装完成后您可以在Windows的[开始]->程序->启动中找到Service Manager.这表明您的MSDE已安装成功.

第二步 启动MSDE
在启动栏中点击Service Manager,运行SQL,此时Windows的任务栏会有如下图标显示.

如果图标不是绿色的箭头,您可以双击它,在如下的窗体中点击[开始\继续]按钮.

第三步 安装数据库
安装里诺仓库管理软件(SQL工程版),安装完成后点击主程序运行,这时会有"连接数据库失败,是否要重新配置数据库",先是,这时弹出的窗体如下图所示:

点击安装数据库按钮,如提示数据库安装成功,则里诺仓库管理软件(SQL工程版)已完装成功. 如提示安装数据库失败,如服务器一栏仍不空,请手工录入(Local),再点击安装数据库按钮,如还不能安装成功,请和我们联系,由我们来为您解答.

如果程序安装失败,请您参见手工安装数据库.

如何联网使用?
在客户端安装好里诺仓库管理软件(SQL工程版)(客户端不用再安装MSDE了),如果连接失败,则在弹出的配置窗体中中的服务器一栏输入安装了MSDE的电脑的机器名.然后点击"测试连接",如提示连接成功,你就可以正常使用我们的网络版的软件了.
如提示连接失败,请参见ODBC配置

注意:
如果您按照我们的帮助安装的，仍然提示数据库连接失败，那可能是您的SQL不是"混合验证模式"。解决的方法是打开注册表，单击Windows的"开始"->"运行"，输入"Regedit",把"HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer\LoginMode"改为0，重启电脑后数据库应该就可以连接上了。


局域网连接设置

如果客户端出现“数据库连接失败”错误提示导致软件不能正常使用，您需要修改您的客户端配置。下面以Windows2000为例：

1、打开控制面板->管理工具->ODBC(数据源),如下图所示：

2、点击"Add"按钮，此时出现在的窗体如下图所示，在列表中选择“SQL Server”,然后点击"完成"按钮。

3、在下面窗体的Name输入框中随便输入一个名称，在[服务器]一栏中输入服务器(即安装了MSDE或SQL2000的电脑)的机器名或IP地址 然后点击“下一步”按钮。
(注意,如果服务端也连接数据库不成功,也可以用ODBC测试一下连接,在服务器一栏中输入(local)或服务器的机器名即可)

4、此时出现的窗体如下图所示，选择“使用用户输入登录ID和密码和SQL Server验证”这一项。
把"连接SQL Server以获得其它配置选项的默认设置"在"登录ID" ID一项输入“sa”,"密码"一项可以保持为空（如果您的SQL有密码，请输入正常的密码），然后点击“客户端配置”按钮。

5、在“网络库”选择“TCP/IP”，然后点击“OK”按钮。

6、点击[OK]按钮,退出[Add Network library Configuration]窗体,在[Microsoft SQL Server Configuration]窗体上点击下一步按钮,此时出现的窗体如下图所示:

7、设置完成,此时再启动里诺仓库管理软件(SQL工程版),应能正确连接上SQL.


附加数据库
如果程序添加数据库失败,请您手工添加数据库.

打开企业管理器,点击菜单"操作"->"所有任务"->"附加数据库",出现的界面如下图所示:

选择一个MDF文件(找到里诺人口管理软件(SQL网络版)程序的安装路径,选择Database下面的mdf文件(database此时应该有两个文件,即为数据库文件),在附加为输入框中输入"PDepot",点击确定.数据库即成功安装.


恢复数据库

首先,您得在您的电脑上安装SQL Server2000企业版.
1. SQL Server企业版安装完成后,点击"开始"->"程序"->"Microsoft SQL Server"->"企业管理器",如下图所示

2. 运行企业管理器,依次展开"Microsoft SQL Servers"->"SQL Server组"->"Local(注:您的机器名)"->"数据库".选中数据库,右击鼠标,选择"所有任务"->"还原数据库",如下图所示:

3. 以里诺的仓库（sql工程版）为例：单击"还原数据库"菜单后,出现如下窗体.
输入还原的数据库名称,选择"从设备"

4. 点击"选择设备"按钮,单击"添加"按钮,在文件名项选择您备份的仓库管理软件的备份文件确定.
回到"选择还原设备"窗体,点击"确定"按钮退出"选择还原设备"窗体.

5.现在回到了"还原数据库"窗体,选中"选项"面板,如下图所示:
在移至物理文件名中,请为两个数据库文件选择一个路径. 比如,我可以把它改为"D:\database\Pdepot_Data.mdf"和"D:\database\Pdepot_log.ldf"
注意,D盘的database文件夹必需存在才行,否则还原数据会失败,如果失败,把路径设成一个存在的路径即可

6 点击"还原数据库"窗体上的"确定"按钮,这时程序会提示你"还原数据库成功"(如下图所示).如果还原失败,请您仔细核对以前步骤,

数据库的恢复方法都是一样的，可互相参考套用，如有疑问可咨询客服为您详细解答。


基本资料

○往来单位资料
点击菜单[基础资料] -> [往来单位] -> [往来单位资料]，启动来往单位资料窗口，如下图所示。

单击新增按钮，在基本资料中输入单位信息，再点击保存按钮，该单位的资料即保存进去了。

○仓库资料
从下拉菜单[基础资料]选择[仓库资料管理]，启动仓库资料窗口，如下图所示。

单击添加按钮，在输入一个仓库名，单击保存，则完成新增操作.
注意：仓库名称不能重复！
○货品资料
点击菜单[基础资料] > [货品资料] -> [货品资料管理]，启动货品资料窗口，如下图所示。

点击新增按钮,在货品资料新增窗体中依次输入货品编码，货品名称,货品规格等资料，输入完成后单击保存即完成货品资料的新增,此时货品资料各项目自动清空,可以接着录入下一条记录.然后退出货品资料编辑窗口。
[入库价]：当您录入入库单据时，入库价作为默认单价;
[出库价]：当您录入出库单据时，入库价作为默认单价;

货品类别管理
点击主界面上的菜单 [基础资料] -> [货品资料] -> [货品类别管理]，弹出如下所示的类别管理窗体：

注意：货品类别的编码必须是偶数，即只能是两位数，四位数和六位数...

○项目管理

点击主界面上的菜单 [基础资料] -> [项目管理] -> [项目管理]，此时的界面如下图所示。

单击添加按钮，在输入一个仓库名，单击保存，则完成新增操作.
注意：工程项目支持树形分类！

查找单据

 从下拉菜单[数据查询]选择[单据查询]，启动单据查询窗口，如下图所示。
111
进入到查找单据界面，在业务类别选择要查找单据的类别如采购收货、销售提货。可以输入单号、开单人、日期范围等信息进行查找，设置好查找的条件后，请单击查找按钮，则在列表中显示所有与查询条件匹配的记录，用鼠标选定一条记录，然后单击显示单据按钮，或直接用鼠标在选定的记录上双击，则可以显示出此单据，然后可以对其进行修改或查阅。


入库

货品入库
我们以采购收货入库为例:

一.采购收货入库单.
在[入库登记]单击[采购收货入库],此时出现的界面如下图所示:

二.添加货品.
在采购收货入库单据中点击新增按钮,选择入库日期,仓库和供应商等信息.

添加货品,点击[增行]按钮(或单击表中的[...]按钮)来添加货品, 填写好单价和数据后,此时出现的界面如下图所示,选择一个要入库的货品,在表格中双击完成添加.

最后在单据添加界面点击[保存]按钮,至此完成货品入库.

货品出库

我们以销售提货出库为例:

一.销售提货出库单.
在[出库登记]单击[销售提货出库],如下图所示:
777

点击[增行]按钮(或单击表中的[...]按钮)来添加货品, 填写好单价和数据后, 最后在单据添加界面点击[保存]按钮,至此完成货品出库.


盘点和调拨

库存盘点和调拨
库存盘点和调拨[其它登记]中,如下图所示

点击[增行]按钮(或单击表中的[...]按钮)来添加货品, 填写好单价和数据后, 最后在单据添加界面点击[保存]按钮,至此完成添加.

注意，如果货品编号为001的货品的实际库存是100,而软件中显示的库存数是80,你在填写盘点单时数量输入20,这样该货品在软件中的库存量就是100了.


导入数据

从Excel导入数据

导入数据

导入货品信息

选择菜单“系统设置”->“导入数据”->“从Excel导入货品资料”,选择一个文件后即会弹出如下窗体

Excel字段名即是Excel表中的字段，您把“源字段名”和“Excel字段名”一一对应好，这样程序才能把信息导入到相应的数据库字段中，比如上图中的货品编码对应货品编码。

注意: 如果导数据过程中发生错误，那么极有可能是您的数据字段没有对应好或者您的Excel中货品编码不是唯一。


报表设计
里诺仓管软件的单据报表样式支持自定义,下面我们以设计入库单为例;

点击菜单"系统设置"->"报表设计"->"出入库单据设计",此时设计界面如下图所示:

如何改变报表的纸张大小?
点击报表设计窗体中的"File"->"Page options",此时出现的界面如下图所示:

Width表示宽,Height表示高,单位为毫米. Portrait表示竖打,LandScape表示横打.

如何改变报表中文字的位置?
比如我想改变成份字段的位置,可以用鼠标先中成份字段,如下图所示

  • "成份"和"oodscf"都处于选中状态,保持选中状态(注意:边框四个角有黑点才表明选中),您可以把他们左移或右移.如果您不想把他们打印出来,您还可以直接按"Delete"键把他们删除.
  • 如果您想套打,您可以把报表中的边框线和有中文字的文本框都删除.
  • 如果您想把货品资料整行下移,选中"Report title".让它处于选中状态,把鼠标移到"Report title"下边框中间的那个黑点处,鼠标变成上下箭头,把Report title高度拖长一些即可.
    设计完成后,点击保存报表设置即完成设计.此时单据样式已变成您设计的样式.

    小窍门:按住"Ctrl"键+上下左右方向键,可以实现精确移动(只移一个像素).
    按住"Ctrl"还可以实现连选.

  • 如何新增一个我想显示的内容?
    比如我想在单据报表中显示我公司的地址信息,我该如何做呢?在入库单据设置界面里,点击左侧的工具栏按钮,选中"插入矩形对象",然后把鼠标移到报表窗体中释放,在文本编辑器中输入您公司的地址信息,点击工具栏上面的保存按钮,然后把地址框拖到您想显示的位置上. 退出报表设计窗体时保存修改,即完成设置.

  • 如何改变标题的显示内容?
    比如我想把表头"货品规格"改成"规格",该如何做呢?在入库单据设置界面里,点击选中"货品规格",如下图所示:
    双击"货品规格"框,在弹出的文件编辑器中把"货品规格"改成"规格",点击上方的"确定"按钮保存就行了. 退出报表设计窗体时保存修改,即完成设置.

  • 如何修改单价的小数点位数?
    比如我想把单价的小数点位数精确到6位,您可以这样设置.
    选定单价框,如下图所示,

    右键单击鼠标,在弹出的菜单中选择"变量格式",把小位数里的数字"2"改成"6",点击确定按钮保存退出.
    退出报表设计窗体时保存修改,下次打印单据时单位就会精确到6位了.

            •


疑难解答FAQs

里诺仓管疑难解答 FAQs

  • 为什么我添加了入库单,而货品的库存数量却没有变化?
  • 单报报表的报表样式可以修改吗?如何修改?
  • 库存报警如何使用?
  • 为什么仓管软件装好了,而我却不能试用?
  • 软件我刚装好,现在我想把里面的初始数据删除掉,我该怎么做?
  • 我想使用最新的仓管软件,请问我该如何正确升级?
  • 我购买注册之后,我以前录入的数据都还在吗?
  • 为什么我导出的Excel文件许多都是乱码?
  • 里诺仓库(工程版)如何输入货品的期初库存数量?
  • 请问里诺仓管支持Internet联网吗?
  • 我想自定义仓管软件的启动界面并把软件的名称改成我们公司的名称,比如某某公司仓管软件,请问可以吗?

    • 问:为什么我添加了入库单,而货品的库存数量却没有变化?
    答:如果您的电脑的操作系统是Windows98或Windows me的话,会出现库存数量不准确的情况,解决办法是安装MDAC2.8(里诺的软件可以下载).

    问:单报报表的报表样式可以修改吗?如何修改?
    答:我们的报表采用的是FastReport,它支持用户自定义,这意味着你可以改变报表的样式(如纸张大小,字段的位置,增加自己公司的标识等等).
    选择菜单 "系统设置"->"报表设置" 里您可以分别修改入库单和出库单的样式.

    问:库存报警如何使用?
    答:在货品资料编辑窗体中设置好某一货品的库存上限和库存下限值,这样当该货品的总库存数量超过库存上限和低于库存下限时,在库存报警中该货品资料就会示出来,起到警示的作用.

    问:为什么仓管软件装好了,而我却不能试用?
    答:在Windows98和Windows Me中,里诺仓管软件的很多功能按钮将会是灰色的,您需要去下载MDAC2.8,然后安装升级即可解决在98和WinMe中不能用的问题了.
    如果您还发现在其它操作系统中不能使用,请向我们报告.lenosoft@21cn.com
    MDAC在我们的网站上有下载,您也可以在网上搜索下载.

    问:软件我刚装好,现在我想把里面的初始数据删除掉,我该怎么做?
    答:选择菜单 "系统设置"->"数据初始化" ,把您需要清除的项目打上勾点击确定就行了.

    问:我想使用最新的仓管软件,请问我该如何正确升级?
    答:在程序之前请先把您的数据库做好备份,见菜单"系统设置"->"数据库备份与恢复" 选择菜单 "实用工具"->"数据库升级工具" ,然后选择您以前的老的数据库点击下一步,在程序的提示下就可以顺利完成升级.

    问:我购买注册之后,我以前录入的数据都还在吗?
    答:当然,注册后您的数据仍在.

    问:为什么我导出的Excel文件许多都是乱码?
    答:我们的软件目前只对Office2000支持较好,如果乱码的情况可能是您的电脑装的是Office2003的缘故,您可以换一台装有Office2000的电脑试试.

    问:里诺仓库(工程版)如何输入货品的期初库存数量?
    答:您可以把货品资料的期初库存数量录进一张盘点单.

    问:请问里诺仓管支持Internet网吗?
    答:SQL网络版支持,但前提是您必须要有一个固定的IP地址.

    问:我想自定义仓管软件的启动界面并把软件的名称改成我们公司的名称,比如某某公司仓管软件,请问可以吗?
    答:可以,修改启动封面您只需要把里诺仓管软件目录下面的splash.bmp替换成您的文件就行了.修改软件的名称见菜单"系统设置"->"系统设置"里.

    以上只是我们一部分的答疑,如果您的问题不在上面,您可以给我们写信:     lenosoft@21cn.com


注 意 事 项

 使用软件之前，请将日期格式设置为标准格式如：2003-10-19如果日期格式设置为03-10-19这样的格式，系统会产生错误。 设置方法一：从开始菜单选择设置/控制面板,打开控制面板后，选择区域设置,在区域设置窗口打开后，再选择日期选项卡，然后在短日期样式一栏中选择yyyy-mm-dd,然后单击确定按钮即可。


注 册 购 买

"里诺仓库管理软件(SQL工程版)"为共享软件,需注册才能永久使用全部功能并享受免费升级服务。没有注册最多只能录入50张单据。只有您的注册，才能使本软件得以持续升级，不断完善。

"里诺仓库管理软件(SQL工程版)"一台电脑的注册费用为 680 元人民币,您注册后可以享受软件的终身免费升级服务，并且还可以得到我们的技术支持服务!

软件注册方法
选择菜单“帮助文件”->“软件注册购买”，则弹出如下窗体，输入正确的注册码，点击“注册”按钮便可。

银行帐号:
开 户 行：招商银行黄石挹江支行
帐　　号：6225 8071 4007 1642
开 户 人：任章勇

开 户 行：中国农业银行黄石市分行胜阳港支行
帐　　号：95599 8076 93415 27216
开 户 名：任章勇

开 户 行：中国工商银行黄石石灰窑支行
帐　　号：6222 0218 0300 1762 182
开 户 人：牛茜

邮局汇款
开户局名称：黄石天津路邮政所
帐号：60522 0004 2011 57699
户名：任章勇
邮编：435000

支付注册费之后，请填写以下注册信息，通过邮件发送给我们，我们的邮件地址是：lenosoft@21cn.com

汇款方式：填写银行名称,比如工行,农行或招行
企业名称：
地址及邮编：
联系电话：
Email：
汇款金额：

服务承诺

凡是购买我们软件的用户，我们会在48小时以前给您寄出注册码。
如果您是在线购买的，只要您银行转帐成功，系统会自动给您发送注册码，而你也同样成为我们的正式用户，享有我们为您提供的一年的升级服务和咨询服务。

联系方法

如有疑问或任何建议请与我们联系
联系方法:
电邮地址: lenosoft@21cn.com
客 服 QQ: 171755331 16380858
售 后 QQ: 759782126
客服电话: 0714-6252277 400-670-2577转1
手机：(0)18672215522